3rd Party Vendor Outage - Business/Admin Emails

Incident Report for Punchh DQ

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2026 - 14:00 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 01, 2026 - 14:00 PDT

Investigating

Due to a 3rd party vendor outage, functionality related to Business and Admin emails (such as Data Exports) are failing to complete successfully. No observed impact to customer email delivery.
Business and Admin Emails Failing to send:
- Functionality related to Business and Admin emails, such as Data Exports
- No impact to customer email delivery
Posted Sep 01, 2026 - 08:47 PDT